Восстановление информации с поврежденных CD-дисков - Ferra.ru

Ferra.ru - компьютерные новости и обзоры железа
Ferra-ru - компьютерные новости, обзоры железа, каталог комплектующих
Поиск
Платформа
Процессоры
Видео
Накопители
Звук
Принтеры
Цифрография
Сети
Mobilis iRU
Корпуса и БП
Охлаждение
Ввод
Аналитика
Интегральное чтиво
Сервисы
Каталог железа
Цены
Форумы
Рассылки
Быстрая подписка
Ferra.ru: cамое интересное о компьютерах за прошедшую неделю

(совместно с Subscribe.Ru)
Экспорт новостей
О проекте
Размещение рекламы
Для авторов
Игры на GameGuru.ru
Всё о компьютерных играх:
» обзоры игр
» игровые новости
» прохождение игр
» чит коды к играм
» игровые форумы
» игры онлайн
» трейнеры
» патчи
» no cd
Ferra > Накопители > Обзоры

Восстановление информации с поврежденных CD-дисков

27.02.2003

Игорь Зубаль, zi12@inbox.ru

 Версия для печати Версия для печати

Как-то, еще более десяти лет назад увидел я в одном популярном журнале статью, где рассказывалось о достоинствах новейших на то время носителей информации – лазерных компакт-дисков. Статья показалась интересной. Там даже была фотография с утопленным, припоминается, в аквариуме CD-диском. Ее вид должен был иллюстрировать исключительную надежность этого типа носителя. В то время компакты были большой экзотикой, тем более для компьютера и оценить правдивость той статьи я, конечно же, не мог. А через какое то время, может быть даже в этом же журнале я встретил другую статью, описывавшею уже некую чудо-машину, предназначенную для чистки и полировки прохудившихся компакт-дисков, подразумевались аудиодиски…

Появившись сначала в мире музыки, компакт-диски быстро завоевали популярность, став основным типом внешнего носителя информации для ПК. Ни один из других типов внешней памяти пока что не получил такого распространения, как обычный CD. Всем хорош CD, да вот только с его поверхностью бывают проблемы. Портятся они достаточно просто. Как бы его не берег, а случайностей избежать нельзя. Даже когда диски просто постоянно перекладываются на столе, то и при этом их поверхность постепенно портится, покрываются мелкими царапинами, тускнеет, а потом начинаются проблемы с чтением. Я уже не говорю, если компакт-диск неудачно падает не той стороной, на него ложится тяжелый предмет с грубой поверхностью. Еще хуже если CD попадает во внутрь изношенного привода, головка которого цепляет по поверхности диска. Пострадать могут даже, казалось бы, тщательно сохраняемые диски. Достаточно в пачку CD-дисков попасть нескольким песчинкам, добавить сюда вибрацию при ношении или вождении на машине, и через некоторое время от трения маленьких песчинок поверхность становится безнадежно испорченной.

С проблемой поцарапанных CD-дисков, наверное, не сталкивался лишь тот, у кого их нет. Если на диске была записана важная информация, то ее потеря по неосторожности выливается в серьезные проблемы. Учитывая, что на сегодняшний день почти вся переносимая информация пишется на CD-носители, то с проблемой ее потери сталкиваешься сплошь и рядом. Пользователь обнаруживает неведомо откуда взявшиеся царапины на поверхности и оказывается в ситуации когда определенные участки CD уже не читаются или читаются со сбоями — как то через раз. Становиться актуальным вопрос — что делать?

Для начала следовало бы разобраться, каким образом расположены данные на CD-носителе и как они могут пострадать. Физически вся информация записывается в активном слое диска, который вместе со светоотражающим слоем находится ближе к верхней стороне CD (относительно привода). Сверху на светоотражающий слой наносится защитное покрытие, обычно лак или краска, защищающее активный слой и информацию от повреждений. Декоративное красочное покрытие, улучшающее внешний вид диска, это также дополнительный защитный слой, предохраняющий поверхность с данными от повреждений. Хотя попадаются CD-R диски у которых верхнее защитное покрытие сведено к минимуму – обе их стороны ярко блестят светоотражающим слоем. У таких дисков активный слой содержащий информацию особенно подвержен повреждениям. Достаточно неглубокой царапины и тонкий слой лака, а вместе с ним и активный слой будут повреждены. На таких участках, если смотреть на просвет, диск просвечивается насквозь. Если в таком месте поверхность не читается, то, как правило, данные потеряны навсегда, восстановить их уже нельзя. Таким образом, вся информация записана в очень тонком активном слое, прикрывает его лишь защитный слой краски, ну а весь остальной объем носителя занимает просто прозрачный материал из которого, собственно, и состоит тело диска – поликарбонат.

Другой способ повреждения CD-носителей, самый распространенный – повреждение прозрачной поверхности тела диска – поликарбоната – т.е. на ней появляются царапины. При чтении эта поверхность просвечивается лучом. Причем просвечивается два раза: один раз, когда луч исходит из лазера, второй раз – это уже отраженный от отражающего слоя луч, направленный в фотоприемник. В этом случае страдает не сама информация в виде питов и лендов в активном слое носителя, а просто теряет оптическую проницаемость прозрачная поверхность диска из-за чего невозможен доступ к информации.

Во многих случаях к информации за поцарапанным слоем поликарбоната все же можно добраться. Раз уж поверхность поликарбоната диска сумели сделать прозрачной на заводе, то почему бы не попытаться, опять же, механическим способом восстановить ее качество в домашних условиях? Кроме того, существуют чисто программные способы коррекции ошибок чтения, и зачастую информацию с проблемных участков удается полностью восстановить, даже не прибегая к какой либо коррекции самой поверхности диска. Ну и самый тривиальный способ – попробовать другой привод — более качественный или более новый образец, с более мощным лазером. Не стоит ожидать хороших результатов от дешевых или изношенных, особенно высокоскоростных CD-приводов.

Если раньше запорченный диск требовал скорее механического восстановления, так как предполагалось и дальше переносить информацию на нем, то теперь, с распространением пишущих CD-R/RW приводов, имеет смысл говорить лишь об снятии с дефективного диска информации — потом ее можно будет записать заново на другой носитель.

Способ восстановления информации с компакт-дисков, на мой взгляд, имеет смысл разделить на три этапа:
1. Программный путь. Часто считать информацию с незначительно поврежденного носителя удается с помощью одних лишь программных средств, не прибегая ни к каким материальным затратам. К таковым относятся утилиты, искусственно замедляющие скорость привода, повышая тем самым надежность считывания. Хоть качественные CD-ROM'ы и способны сами понижать скорость при неудачных попытках чтения, однако, практика показывает, что изначально пониженная программой скорость дает гораздо лучший результат и нечитаемых секторов остается гораздо меньше. Но далеко не все приводы компакт-дисков поддерживают принудительное ограничение скорости, это относится к самым дешевым и поэтому самым проблемным устройствам. Другой класс утилит, это те, которые реализуют программный алгоритм считывания и коррекции данных с поверхности компакт-диска. Так программа может заставлять привод десятки раз подряд читать поврежденный участок, по крупицам извлекая из него информацию и складывая ее разрозненные части. Если даже не удастся полностью прочитать все биты, то здесь программа попытается склеить файл, заменив недостающие части нулями. Для некоторых типов файлов такой способ вполне приемлем. Однако подобная реализация восстановления данных обычно занимает довольно много времени.

2. Аппаратный. Далеко не все приводы для оптических носителей читают диски одинаково хорошо. Разные приводы отличаются как качеством исполнения механической и оптической части, так, видимо, и мощностью лазера. Поэтому старые CD-ROM'ы чрезвычайно плохо читают диски CD-R/CD-RW, отражающая способность активного слоя которых гораздо меньше, чем у дисков, отпрессованных через матрицу. Кроме того, производители приводов реализуют в этих устройствах специальные системы и алгоритмы для коррекции ошибок. В упрощенном виде это выглядит примерно следующим образом. Если привод не может справиться с чтением некоторого участка, то он старается повторить считывание на меньшей скорости. Если вновь неудача, то при очередной попытке скорость будет понижена еще ниже, и так далее. Пока участок не будет прочитан или принят как нечитаемый. Однако не все приводы могут регулировать свои скорости, к тому же набор доступных скоростей у каждой модели ограничен определенным числом. Чем более низкие скорости доступны в этом наборе, тем большая вероятность прочтения поврежденных участков. У самых дешевых моделей механизмы коррекции ошибок реализованы очень плохо, да и возможность регулирования оборотов, часто не позволяет переключаться на минимальные скорости чтения.

Поэтому попытка аппаратного решения проблемы с поврежденным диском просто сводится к банальной замене привода на более качественный. При умеренной степени повреждения поверхности, хороший привод способен справиться с тем, что недоступно изношенному или дешевому устройству.

3. Механический способ. Чаще всего проблемы чтения возникают от царапин прозрачной нижней стороны компакт-диска. Из-за поглощения луча лазера этими непрозрачными бороздами от царапин доступ к данным активного слоя становиться невозможен. Хотя сами царапины имеют мизерную глубину, обычно порядка нескольких микронов, максимум – сотые доли миллиметра, и, как правило, относительно небольшие размеры. Тело же прозрачного материала диска — напротив, составляет почти миллиметр. Поэтому часто, чтобы восстановить читабельность оптического носителя, достаточно обработать механическим способом лишь очень тонкий поверхностный слой поврежденного диска, то есть отполировать его. Отполированная поверхность вновь приобретает прозрачность, и луч лазера беспрепятственно может считать информацию с находящегося глубже активного слоя. Хотя на практике проблема полировки компакт-дисков довольно сложная задача. Всегда существует вероятность еще большего повреждения поверхности уже в процессе полировки. Этой проблемы мы коснемся в самом конце статьи.

Процесс пошел…

С каких же средств стоит начинать восстановление информации на CD? Ясно, что с программных. Во-первых, при помощи программных средств вы ничем не рискуете, нельзя что-либо испортить еще хуже. Представленные ниже программы не потребуют дополнительных финансовых затрат, только времени, иногда очень большого. С помощью тех же программных средств можно и установить степень повреждения компакт-диска, по крайней мере, для того, как это видит конкретный CD-привод. Если же с помощью программного восстановления данных не удалось достичь требуемого результата, то тут уж имеет смысл повторить все сначала, но только уже на другом приводе, более качественном. Если результат опять не достигнут, остается последний шанс – механическая обработка. Полирование – процесс очень ответственный, требует специальных средств, навыков и терпения. Но самое главное, при попытке восстановить поверхность диска полировкой, его запросто можно испортить еще в большей степени, да так, что уже ничего не поможет. Все эти этапы мы рассмотрим в отдельности.

Программы для работы с CD

Ограничители скорости. Для начала стоит испробовать ограничители скорости. Это простое средство, тем не менее, иногда оказывается весьма эффективным, работает даже с приводами которые сами могут понижать скорость. Принудительное понижение скорости всегда предпочтительнее даже в тех случаях, когда привод может сам понижать скорость в результате работы его системы коррекции ошибок. Особенно кода читаются несбалансированные, вибрирующие на высоких оборотах диски. Переход диска на пониженную скорость тоже сопровождается вибрацией, возможно даже большей, чем на постоянной скорости, сказывается момент инерции массы диска. Поэтому, если диск вращается изначально на низкой скорости, то это всегда даст гораздо более надежный результат, чем систематические понижения, а потом повышения скорости в результате работы системы коррекции ошибок привода. Результат хорошо виден на графиках (рис.1), здесь один и тот же диск читался на 40Х и 20Х скоростях привода TEAC CD-540. Как видно, график чтения на большой скорости сопровождается резкими провалами, близкими к потере информации. График же в 20Х режиме вполне нормален, тем более, нельзя сказать, что его суммарная скорость ниже, чем у 40Х режиме.

Рис. 1.

В качестве утилит понижающих скорость CD-приводов можно попробовать CDSlow, Nero Drive Speed, а так же VMenedger CD-ROM. Все они свободно распространяются и бесплатны. Наиболее удачным вариантом среди них, на мой взгляд, является CDSlow. После инсталляции CDSlow ставит свой значок в системный трей, откуда, при щелчке правой кнопки мыши, открывается гибкая система настроек программы. Интерфейс на русском. Сначала имеет смысл проверить привод на возможность управления его скоростями: «Определение скорости/Полный перебор». Далеко не все CD-ROM’ы могут менять свои скорости, да и наборы установок у разных приводов разные. С помощью левой кнопки можно на ходу поменять скорость из списка доступных, в особенно выгодном положении здесь находятся приводы ASUS, у которых скорости можно менять от 4Х и до максимума, через одну (рис.2). CDSlow постоянно совершенствуется и на сегодняшний день программа доступна с версии v.1.0 по v.2.1.

Рис. 2.

Nero Drive Speed, продукт известного разработчика. Ее версии постоянно обновляются, знает много приводов. При запуске программы получаем значок в трей, при двойном щелчке по которому появляется окно программы, откуда и производится выбор скорости (рис.3). Программу можно установить на загрузку при запуске Windows. А при нажатии кнопки «Опции», попадаем в окно настроек, где можно выбрать язык интерфейса, в том числе русский, а так же детектировать доступные приводу скорости. VMenedger CD-ROM, как и CDSlow, разработана в России.

Рис. 3.

Способ управления утилитой аналогичен с Nero Drive Speed, – после щелчка по значку в трее появляется окно с настройками (рис.4). Интерфейс и хелп изначально на русском. Показывает несколько завышенные скорости, но это не столь важно.

Рис. 4.

Хочу добавить, что использовать эти утилиты стоит не только для решения проблем с чтением, но и вообще всегда при эксплуатации CD-ROM’a. Все они могут работать из автозагрузки. Выставив CD-ROM на среднюю скорость, вы не только продлите жизнь привода и повысите надежность чтения, но и избавитесь от лишнего шума, привод станет работать почти неслышно. Кроме того, на пониженных скоростях нет риска того, что диск разорвет внутри привода, чем славятся современные высокооборотные CD-ROM’ы. Да и в скорости реальной работы потеря может быть незначительна, а то даже может наблюдаться и ее выигрыш, если диск плохо читается на высокой скорости, либо данные считываются фрагментально.

Проверка поверхности. Однако же если диск явно поврежден, то для начала стоило бы выяснить степень его повреждения. Сделать это можно с помощью утилит, сканирующих поверхность компакт-диска на предмет ошибок. Тест сканером не является показателем абсолютным, он сильно привязан к аппаратной части конкретного привода. Одна программа-сканер может находить больше поврежденных секторов, другая – меньше. При этом не исключено, что программа для восстановления данных с легкостью сможет прочитать их все. Да и на более надежном приводе ситуация может измениться, вплоть до полного и безпроблемного чтения всей поверхности.

Здесь может помочь CD-ROM Drive Analyser Pprogram. Программа проверяет поверхность компакт-дисков на предмет читабельности, отображая на графике состояние и скорость этого процесса (рис.5). Резкое падение скорости говорит об проблемах на этом участке. Если же спады на графике окрашиваются в красный цвет, то это признак нечитаемости данных.

Рис. 5.

Количественная оценка повреждений с помощью Drive Analyser весьма условна. Один отмеченный красным блок у него содержит 1000 секторов. Это может означать, что в этом блоке поврежден как один сектор, так и вся тысяча.

Другая утилита, которая может строить аналогичные графики чтения CD является Nero CD Speed. График проверки строится аналогичным образом, но на сетке еще отображается и число оборотов шпинделя привода в процессе чтения (рис.6).

Рис. 6.

Однако более наглядно процесс проверки будет представлен, если воспользоваться тестом Scan Disc из комплекта Nero CD Speed: Extra/Scan Disc (рис.7).

Рис. 7.

После проверки поверхности можно судить о степени повреждения диска. Компакт-диск важно просканировать на разных скоростях, а так же, хорошо бы на других приводах. Если при всех тестах поврежденные участки на графиках всегда остаются на одних и тех же местах и их количество не меняется или меняется слабо, то это уже, наверняка, будет свидетельство серьезных дефектов поверхности, а не проблем с приводом. Значение имеет не только абсолютное количество поврежденных секторов, но и их расположение. Гораздо легче восстановить данные из многих разбросанных раздельно поврежденных секторов, чем если все они будут сконцентрированы в одной области. Чем большее количество поврежденных секторов не может прочитать привод, тем больше времени уйдет на попытку восстановления информации и тем меньшая вероятность остается на успешный в полной мере исход.

Копирование данных с CD. При копировании информации с CD обычными средствами, на поврежденных участках попытки копирования повторяются несколько раз, если все они неудачные, то копирование прекращается. Однако существуют специальные программы, которые обладают гораздо лучшими алгоритмами копирования и восстановления данных с запорченных участков CD. Такая программа много раз подряд пытается прочесть поврежденный участок, все время собирая и анализируя добытые данные, пытаясь по разрозненным частям восстановить информацию. Если даже вся информация не может быть прочитана и восстановлена корректно, то и в этом случае процесс копирования не прекращается, а в конце программа пытается «склеить» файл, что бы он был пригоден для использования, даже при потере некоторого количества данных. Очень часто подобные утилиты без ошибок восстанавливают те участки, которые приведенные выше утилиты-сканеры видят не иначе как поврежденными. В другом случае, если даже потерянные данные и имеются, то их количество удается многократно уменьшить, а потом собрать файл без потери его атрибутов. В случае с музыкальными и видео-файлами такой способ очень хорошо работает. Небольшие участки потерянной информации остаются здесь практически незаметными.

Утилиты копирования данных с CD. Очень хорошо себя зарекомендовала в плане восстановления информации с запорченных CD-дисков программа CDChck, текущая версия v.3.0.1.43. Начнем с того, что программа бесплатна для некоммерческого использования, а так же поддерживает многоязыковый интерфейс, где присутствует и русский. Но главное достоинство CDChck, это высокая вероятность восстановления данных и умение собирать работоспособные файлы даже при невозможности восстановления некоторой части информации, что в основном характерно для звуковых и видеофайлов.

Интерфейс CDCheck совершенно нагляден (рис.8). Что бы начать восстановление файла или группы файлов и каталогов, их следует выделить в области дерева каталогов.

Рис. 8.

После нажатия кнопки восстановления сначала будет предложено окно настроек (рис.9). В области повторов попыток чтения стоит число повторов сверх первой попытки, так что, если здесь даже будет стоять ноль, то программа будет пытаться восстановить секторы с первого раза. Большое число попыток здорово замедляет общую скорость работы.

Рис. 9.

По моему мнению, не имеет смысла ставить количество попыток восстановления больше трех. После начала восстановления в нижней области указывается список нечитаемых и поврежденных секторов, если такие окажутся. Здесь нужно оговориться. Если скажем, утилита проверки CD, например, CD-ROM Drive Analyser находит на диске нечитаемые секторы, то это еще не значит, что эти секторы будут нечитаемыми для CDCheck. У CDCheck гораздо лучший алгоритм считывания, поэтому она может без потерь копировать те данные, которые для других программ кажутся потерянными.

Перед началом сеанса восстановления необходимо установить скорость привода CD диска на минимальное возможное значение, если, конечно, его конструкция вообще предусматривает возможность регулировки. Сделать это можно с помощью одной из вышеприведенных утилит. Потеря времени от понижения скорости, по сравнению с временем анализа и восстановления будет не слишком значительна. Зато надежность восстановления информации многократно возрастет. Хотя многие приводы при проблемах чтения способны сами понижать скорости до минимального значения, однако опыт показывает, что изначальное программное ограничение скорости дает заведомо лучший результат. CDCheck конечно же очень тесно взаимодействует с приводом. Нечитаемый сразу сектор сначала пытается прочесть программно-аппаратная часть коррекции ошибок самого привода, причем при каждом повторном задании на чтение. Далее контроллер привода уже отправляет ответ об успешности или неудаче попытки чтения, после чего утилита восстановления данных вновь берет управление приводом. Системы коррекции ошибок разных приводов работают по-разному, а значит, это занимает разное время. Особенно медленно работает система коррекции ошибок TEAC'ов, что во многих случаях делает использование этих, без сомнения, отличных приводов неудобным. При большом количестве сбойных участков восстановление с помощью TEAC'a может растянуться на огромный промежуток времени. Кроме того, на некоторых участках наблюдаются очень длительные остановки, возможно даже зависания. Выйти из ситуации здесь можно следующим образом – нажатием кнопки «Eject» на самом приводе. Лоток с диском выедет, экран станет синим, но после загрузки диска обратно и повтора программа заработает дальше, а зависший сектор будет признан нечитаемым. В случае с CDCheck такой способ весьма надежен. Гораздо быстрее приводов TEAC работают ASUS'ы, и притом, читают практически так же хорошо. Нечитаемые и секторы с ошибками CDCheck отображает в виде списка в нижней области своего окна (рис.10)

Рис. 10.

Имеется у CDCheck и возможность проверки поверхности диска. Однако пользы с нее мало, так как при сообщении о первой же ошибке проверка прекращается. Другая функция CDCheck позволяет сравнивать между собой два источника, скажем, оригинала и восстановленной копии, с тем что бы определить различия в них.

Другая программа с помощью которой возможно производить копирование с поврежденных дисков – Skopin File Copier. Программа писалась для восстановления информации с FDD-дискет, дубликатов дискет, а так же CD-дисков, тоже бесплатна. Данные разбивает на секторы объемом 512 кб. Интерфейс чрезвычайно прост – всего три кнопки (рис.11).

Рис. 11.

Если программа восстановления запущена и ей попадается первая ошибка, то появляется окно с вопросом о вариантах дальнейших действий (рис.12). Здесь нужно задать игнорировать этот и все дальнейшие нечитаемые секторы. Теперь на следующих сбойных секторах утилита сначала застрянет, пытаясь их прочесть, а если это не удастся, то просто пропустит без лишних вопросов, заменив нулями, и соберет файл без них.

Рис. 12.

Никаких дополнительных настроек для восстановления не предусмотрено. Сеанс работы Skopin File Copier проходит довольно долго.

Вот еще одна программка с весьма экстравагантным названием – CillCopy. Не знаю, почему автор решил назвать ее именно так. Возможно, что бы указать на возможность копирования убитых файлов с любых дисков, кстати. Программа бесплатна, сайт ее поддержки: http://killprog.narod.ru/.

При инсталляции CillCopy внедряется в Проводник (Обзор). Теперь при клике правой кнопкой по любому файлу или каталогу в контекстном меню будет присутствовать возможность его восстановления с помощью CillCopy. При выборе этой опции сразу же появляется (рис.13) где предлагается выбрать путь для размещения копируемых и восстанавливаемых объектов.

Рис. 13.

Полезно сначала заглянуть в окно настроек (рис.14).

Рис. 14.

При обнаружении ошибок здесь возможны разные варианты: пропуск (skip) файла – для нас не подходит; promt – при первой же ошибке выдаст дополнительное окно, где спросит, что делать (рис.15).

Рис. 15.

Здесь имеет смысл задать вылечивать все ошибки в дальнейшем, воспользовавшись кнопкой «Heal». Возможен так же режим повторения чтения (retry), там даже можно задать какое-то время в миллисекундах. Непонятно, что это за время. На практике на ошибках программа застряет надолго, на некоторых даже очень, скорее всего навсегда. В случае же выбора функции исправлять ошибки, копирование происходит очень быстро, а все нечитаемые секторы моментально заменяются нулями, правда, и качество восстановления здесь обратно пропорционально скорости. Но надо отдать должное, видеофайлы запускаются и идут до конца, лишь на местах замещенных ошибок всплываю серьезные артефакты.

Так же для восстановления данных с компакт дисков можно воспользоваться IsoBuster, текущая версия v.1,2 (рис.16). Эта утилита так же поддерживает множество языковых интерфейсов и является условно-бесплатной.

Рис. 16.

С помощью IsoBuster можно извлечь файл с CD и разместить его на винчестере. При нахождении сбойных секторов программа предложит игнорировать их. Хотя собирает файл содержащий проигнорированные секторы IsoBuster далеко не самым удовлетворительным образом. Так мне ни разу не удалось запустить ни один MPEG-4 фильм после восстановления IsoBuster'ом. Кодек неизменно заявлял, что он имеет дело с неизвестным ему форматом. И это в отличие от трех приведенных выше утилит, которые с восстановлением видеофайлов справляются без особых проблем. С музыкальными файлами IsoBuster справляется лучше, они играют после восстановления.

Итак, чего можно добиться с помощью рассмотренных утилит? В лучшем случае программа восстановления скопирует информацию с CD без ошибок, и файлы будут соответствовать оригиналам. Если же нечитаемые секторы все-таки будут, то и в этом случае состояние файла вполне может устраивать. Так, например, звуковой mp3 файл у которого на музыкальном проигрывателе неслышимыми оставалось до 85% от общего времени, после восстановления CDCheck приобрел звук на всей длительности, можно было разобрать все слова песни, хотя удовольствия от такой музыки, конечно, было мало. Зато звуковые файлы у которых неслышимо 15-20% в большинстве своем вполне нормально восстанавливаются без заметной потери качества музыки, даже если при этом присутствует некоторое количество разрозненных нечитаемых секторов. То же можно сказать и о видеофайлах. Конечно, при больших областях из нечитаемых секторов в тех местах хорошо заметны кратковременные артефакты. Однако теперь уже фильм не будет намертво зависать при просмотре на этих местах, и его можно будет копировать на другие носители. В случае возникновения ошибок при восстановлении программных файлов, никак нельзя гарантировать их пригодность и полную работоспособность. Остается надеяться только на то, что такие файлы удастся восстановить вообще без ошибок, что иногда вполне достижимо.

Времени восстановительные работы занимают обычно много. Так копирование фильма в MPEG-4 с запорченного диска с помощью CDCheck заняло 1,5 часа. При этом было отмечено 250 нечитаемых и содержащих ошибки секторов. Тот же диск с помощью Skopin File Copier удалось скопировать только через 4,5 часа. При этом использовался привод CD-ROM ASUS CD-S520/S, установленный на 4Х или 8Х скоростные режимы. В случае с приводами TEAC времени на восстановление уходит гораздо больше, сказывается специфика медленной работы системы коррекции ошибок.

Механический способ восстановления CD

К попытке механического восстановления поверхности компакт-диска стоит прибегать только тогда, когда все остальные способы уже испробованы и терять больше нечего. Потому как с помощью механического воздействия на поверхность диска, можно как улучшить его читаемость, так и вконец испортить диск, без всякой надежды на дальнейшее восстановление информации каким либо способом.

Из механических повреждений следует, прежде всего, разделить продольные и поперечные царапины. Так, даже очень жирная поперечная царапина (такая, что направлена по радиусу, поперек дорожек) может не оказать существенного влияния на читабельность диска. И напротив – даже слабая царапина, направление которой совпадает с окружностью дорожки, способна сделать нечитаемым огромный участок поверхности диска. На это следует обращать внимание при полировке. При механической обработке уже существующих царапин, никак не избежать появления множества новых, хотя и очень маленьких – появившихся от действия полировального материала. Поэтому свое движение при обработке всегда следует направлять в перпендикулярном относительно дорожек направлении (вдоль радиуса диска), таким образом, появятся только поперечные, наименее опасные новые царапины.

Полировать диски можно вручную или с помощью полировального круга, посаженного на шпиндель двигателя. В последнем случае это может быть точильный станок, на который установлен мягкий войлочный круг, шпиндель токарного станка или же электродрель, зажатая на столе в струбцине или тисках с зажатым в патроне войлочным кругом. Полировальный круг должен быть идеально отцентрирован. В случае токарного станка, его сначала выравнивают резцом на больших оборотах. С точильным станком или электродрелью сложнее. Здесь биение круга можно убрать, пройдясь по нему на скорости обычным рубанком для дерева с хорошо отточенным лезвием. Для того же можно использовать и рашпиль.

В качестве полировального состава можно использовать пасту гои, растворенную в керосине или уайтспирите. Паста гои, это зеленое, довольно плотное вещество, обычно в виде куска, напоминающего зеленый камень. Она используется для полировки, и, как правило, ее куском натирают вращающийся на двигателе круг. Однако для более тонкой полировки, как в нашем случае, лучше наносить растворенную пасту гои непосредственно на поверхность CD-диска. Так как растворяется она плохо, то можно не растворять полностью кусок пасты гои, а залив его растворителем, потом натирать тампоном из ваты и наносить вещество с помощью этого тампона на поверхность диска. Пасту следует наносить периодически, не допуская ее высыхания в процессе полировки, следя за тем, что бы в ее состав не попадали нерастворенные кусочки, способные сделать царапину. Полировка ведется перпендикулярно к дорожкам компакт-диска.

Другим составом для полировки может стать обычная зубная паста, тоже наполовину растворенная водой. Здесь не следует экономить, покупая самые дешевые пасты. Важно, что бы в пасте не было крупных абразивных частичек, способных нанести существенные царапины. Хотя полностью избежать этого не удастся. Поэтому пользоваться зубной пастой следует с максимальной осторожностью, ориентируя компакт-диск к полировальному кругу так, чтобы направление движущейся части было перпендикулярно к дорожкам CD. Засохшую на кромке полировального круга пасту следует периодически снимать рашпилем. Так как образование мелких царапин при полировке зубной пастой, в принципе, неизбежно, то слишком длительная полировка этим составом может иметь и обратный эффект. Так при полировке на протяжении некоторого времени можно восстановить какой-то участок диска, а при продолжении его полировки – уже испортить его. Потому что постепенно там будет появляться все больше и больше царапинок, в конце концов, покрывших поверхность непроницаемой сеткой. В процессе полировки следует почаще проверять поверхность диска программой-сканером, что бы видеть в каком направлении идет процесс.

Прежде чем начать полировать ценный диск с помощью круга, потренируйтесь на каком нибудь ненужном CD-диске. Это очень важно, так как нужно точно выверить нажим. Малейшее его превышение – и материал диска нагревается, начинает плавиться, на поверхности появляется широкая, глубокая борозда, которую уже невозможно устранить. Нажим должен быть очень слабым, длительностью всего несколько секунд, иначе материал компакта разогреется и испортится. Когда нужные практические навыки будут получены, можно приступать к ответственной полировке нужного диска. Несмотря на всю автоматизацию, занимает этот процесс много времени, иногда не один час, притом, что результат далеко не всегда оказывается положительным.

Вручную можно полировать теми же полировальными составами, однако, все движения здесь уже придется проделывать пальцами рук с помощью кусочка войлока или мягкой тряпочки, натирая поврежденную поверхность CD. Полировальный состав наносится на поверхность диска в растворенном виде. Сам диск ложится на мягкую ткань на ровной поверхности, иначе его обратная окрашенная сторона, а под ней поверхность активного слоя может повредится при нажиме. Все движения в процессе полировки должны производится перпендикулярно концентрическим дорожкам, то есть – по радиусу.

Такими способами можно отполировать отдельные не слишком глубокие царапины. Часто это требует много времени и доставляет массу неудобств. Если диск изуродован полностью, скажем, в футляр с дисками попал песок, и вы катались с ними на горном велосипеде по пересеченной местности, – то такие диски вряд ли уже подлежат восстановлению. Хотя, попробовать можно…

Иногда можно услышать заблуждение, что если поверхность поцарапанного CD-диска покрыть неким специальным раствором, называется и глицерин или же рафинированное растительное масло, то диск будет лучше читаться. Это не что иное как иллюзия. Да, покрытая прозрачным раствором поцарапанная поверхность будет действительно казаться гладкой и блестящей. Однако же сами царапины от этого никуда не денутся. Мало того, глицерином или маслом можно вымазать головку привода – тогда это уже будет действительно проблема. Другим средством, предназначенным для улучшения читабельности приводов, являются всевозможные чистящие составы. Это выглядит как диск с установленной на нем щеточкой или тампоном. Обычно к ним прилагаются специальные чистящие жидкости. Не могу сказать насколько это эффективно в смысле очистки, но то, что таким средством можно запросто угробить привод, это уже неоднократно доказано на практике. Если уж привод требует чистки, то делается это посредством его полной разборки специалистом, с очисткой не только оптической головки, но и механики. Часто это дает самые положительные результаты.

Вот и все мои знания, которыми я хотел поделиться на страницах этой статьи. Буду рад, если изложенный материал поможет вам восстановить важную информацию с испорченных CD. И не поминайте худым словом, если, потратив много сил и времени, у вас ничего не получится, такое тоже бывает…
Рамблер - Тор100 - Магазины - Покупки - Путешествия - Право - Здоровье - Компьютеры - Лето - Недвижимость
Сервисы: Почта - Группы - Фото - Работа - Поиск файлов - Домены - Словари - Карты - Открытки - Мобайл
Сегодня: Новости - Финансы - Спорт - Погода - Руметрика - ТВ-Программы - Гороскоп - Москва
Copyright © 2002-2004 ООО "Рамблер Интернет Холдинг"
Copyright © 2002-2004 ЗАО "НаКарте.Ру"
Email: info@ferra.ru
[AD-SIZE]
Copyright © 2000-2003 ИД "Компьютерра"

Работает на Saitistika